Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: 1997 Jeep Wrangler All Guages Dead

  1. #21
    SUPPORTER 97TJGUZZY's Avatar
    Join Date
    Feb 2011
    City
    Chapin
    State
    SC
    Posts
    11,956
    I plan to do some more troubleshooting tonight, hopefully I can get this figured out.
    --Brooks

  2. #22
    SUPPORTER 97TJGUZZY's Avatar
    Join Date
    Feb 2011
    City
    Chapin
    State
    SC
    Posts
    11,956
    So basically I have something intermittent. It seems that I will have no gauges, but if I remove the cluster and let something reset and plug it back in, the gauges work and the self test works. But after performing the self test then my needles flicker with the key off, and when I try to turn it on again, I get no gauges.

    I got some diagnosis steps that Trip worked up for me that I plan to try tonight. Documenting them here for future reference:

    1. Measure between pin 3 on the OBD and ground - should be 2.5v
    1A. Measure between pin 11 and ground - should be 2.5v
    If I have that voltage then i need to replace the cluster, but if I dont I need to keep testing via step 2.

    2. Disconnect Cluster and repeat step 1 & 1A. If I now have 2.5v on the bus - replace the cluster
    if not go to step 3.

    With the cluster disconnected locate and disconnect the Airbag module connector (the one with the twisted wires).
    3. Repeat steps 1 & 1A if that now shows voltage, the airbag module is bad, reconnect gauges and they "should" work

    if that doesnt work repeat steps 2 and 3 with ECU disconnected instead of the cluster.
    --Brooks

  3. #23
    SUPPORTER 97TJGUZZY's Avatar
    Join Date
    Feb 2011
    City
    Chapin
    State
    SC
    Posts
    11,956
    Ran through the above sequence and it is still not repeatable. It looks like there are 4 possibilities that are causing my problem.

    1. The cluster is bad/intermittent issue
    2. The connection at the cluster is bad
    3. The PCM is bad
    4. The Airbag module

    Hopefully I can make it over to Tripps place and we are planning to swap out a few of these items to find the culprit.

    If anyone in the chapin/irmo area has a 97-2000 wrangler that will let me swap at least the cluster it would be awesome. It takes about 5 minutes to swap.
    --Brooks

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Clubs, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.